Need Help?

Devices and Browser Compatibility

Note: To access CloudKampus, you will need latest version of browser software we support. They are:

  • Google Chrome (recommended)
  • Firefox
  • Safari
  • Internet Explorer 11
  • Microsoft Edge

If you still have problem accessing CloudKampus, clear cache memory in your browser and try again. Please also note that you need a smart mobile device or a computer with enough hardware capacity – CloudKampus does not work in a feature or essential phone.

Request for demo